Monday, May 04, 2009

Upgrading a Philips Showline 9350i from Vista to Windows 7 RC

A little while ago I wrote about upgrading my Philips media centre to Vista. Microsoft have just released Windows 7 RC and the media centre was starting to need a reboot more and more so I thought I'd try the upgrade. I've been using Windows 7 beta at work for a while and find it much faster and better to use than Vista.

To my surprise, I chucked the Windows 7 RC x86 DVD in the box, ran the upgrade and an hour later I have a fully functioning Windows 7 media center! It transferred all of my settings and recordings etc... and plays back all my movies, TV progs etc perfectly. The new media center interface looks much nicer than the Vista one.

I'll update the blog when I've used it a bit more but am very happy so far....

9 Comments:

Blogger john said...

Hey - How's the experiment with windows 7 going?

I'm keen to upgrade from vista is it fixes all the issues (http://www.outside-the-box.com/?p=118).

I'll probably take the plung at the weekend but I'd appreciate your feedback

John

3:24 pm  
Blogger Jelte said...

I too have upgraded to Win 7 (7100 to be precise) and it works wonderfully. Feels more responsive and certainly looks better than Vista. Front panel Vista drivers work on Win 7. Win 7 MC looks nicer and works faster than VMC. Same standby-issues as with Vista but I have not looked into these.

All in all a hapy user.

Jelte

1:32 pm  
Blogger James White said...

I've had a few problems:

Sometimes when I change channels the audio goes out of sync.

I have to manually Zoom some channels to fit my TV.

Other than that, its been fine.

I'm going to wipe it this weekend and install the final version of Windows 7 I now have. I'll report back in a week :)

10:31 am  
Blogger James White said...

Having done a fresh install with the final copy of Windows 7 (RTM), all of the previous problems disappeared. I'd recommend upgrading if you can, it looks a lot nicer and has some nice features.

12:56 pm  
Blogger 6040 said...

Hello James,

I also did a clean install of W7 (8600) but the software was unable to detect the NVIDIA Dual TV Tuner and I couldnot use the sound analog tulip output.

Can you tell what drivers you used??

Thanks in advance
Jos Bakker

11:41 pm  
Blogger James White said...

I don't use the analogue tuners anymore I'm afraid. I use a DVB-T dual tuner USB stick.

The audio just worked for me. If you want a copy of the XP drivers to force Windows 7 to use drop me an email (james at verydodgy.com)

2:49 pm  
Blogger Olivier said...

to 6040: You should use the original nvidia driver to use the nvidia dual analog tuner under windows 7. It works perfectly under windows 7.

12:49 pm  
Blogger Roelf de Meer said...

Do you still have the tuner drivers? I would like to have them for the 9350i

2:19 pm  
Blogger Roelf de Meer said...

Do you still have the tuner drivers? I would like to have them for the 9350i

2:19 pm  

Post a Comment

<< Home


   
In Association with Amazon.co.uk